Сделать домашней|Добавить в избранное
 

CCIENetLab - Подготовка к экзаменам
CCNA, CCNP и CCIE

 
» » Особенности EIGRP Router-ID

Особенности EIGRP Router-ID

Автор: Sauron от 9-06-2015, 14:29
Router-id определяется протоколом EIGRP как наивысший Loopback адрес, или наивысший IP адрес, если нет Loopback адресов.
Проблема, которая часто встречается с редистрибуцией маршрутов, в связи с наличием маршрутизаторов с одинаковыми Router-ID, может быть понята с помощью данной сетевой топологии.

Особенности EIGRP Router-ID

Здесь три роутера и 2 роутинг домена: RIP и EIGRP AS 1. Роутер R3 выполняет редистрибьюцию маршрутов полученных из RIP в протокол EIGRP.

Конфигурация R1:
hostname R1
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial1/0
 encapsulation frame-relay
 no shut
!
interface Serial1/0.1 point-to-point
 ip address 172.16.13.1 255.255.255.0
 frame-relay interface-dlci 103   
!
router eigrp 1
 network 172.16.0.0
 no auto-summary
!


Конфигурация R2
hostname R2
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
! 
interface Loopback1
 ip address 10.0.0.10 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.3.2 255.255.255.0
!
router rip
  version 2
  network 172.16.0.0
  network 10.0.0.0
!


Конфигурация R3
hostname R3
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface Ethernet0/0
 ip address 172.16.3.3 255.255.255.0
!
interface Serial1/0
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 172.16.13.3 255.255.255.0
 frame-relay interface-dlci 301   
!
router eigrp 1
 network 172.16.0.0
 redistribute rip metric 1 1 1 1 1
 no auto-summary
!
router rip
  version 2
  network 172.16.0.0
!


Посмотрим на таблицу маршрутизации роутера R3:

Особенности EIGRP Router-ID

Из предыдущего вывода мы видим, что R3 выучил сеть 10.0.0.0 через RIP. Взглянем также на таблицу топологий роутера R3

Особенности EIGRP Router-ID

Через процесс редистрибуции, данный маршрут был впрыснут в таблицу топологий EIGRP как внешний. Роутер R3 также показывает, что он является источником данного внешнего маршрута, его EIGRP Router ID = 2.2.2.2
Так как R3 впрыснул маршрут 10.0.0.0 в таблицу топологий EIGRP, то мы ожидаем, что данный маршрут появиться на R1. Посмотрим на таблицу маршрутизации и таблицу топологии EIGRP на роутере R1

Особенности EIGRP Router-ID

Из вывода мы видим, что ожидаемого маршрута нет ни в таблице маршрутизации, ни в таблице топологий. Давайте еще раз глянем на соседство роутера R1.

Особенности EIGRP Router-ID

Все нормально! Однако если мы посмотрим более внимательно на таблицы топологий обеих роутеров, мы обнаружим, что R1 и R3 имеют одинаковый EIGRP router ID. Если мы запустим на R1 команду show ip eigrp events

Особенности EIGRP Router-ID

То увидим, что R1 всё же получает маршрут к сети 10.0.0.0/8, но отбрасывает его из-за дубликата router-id. Оказывается, что в общем случае EIGRP всё равно, какие router-id у вас в AS. Ровно до тех пор, пока на одном из роутеров с одинаковым router-id не настроена редистрибьюция. Тогда инжектированные маршруты получают специальную метку с router-id роутера, который сделал редистрибьюцию. Если роутер получает маршрут с такой меткой и видит, что его router-id совпадает, то такой маршрут отбрасывается.

В данном случае у нас была ошибка в конфигурации. В сети были случайно настроены одинаковые Loopback адреса. На роутере R1 есть Loopback0 с адресом 2.2.2.2/32 и на R3 такой же Loopback0 с тем же адресом. Поэтому EIGRP Router-ID были выбраны одинаковы. Исправим ситуацию, заменив адрес Lo интерфейса R1 на 3.3.3.3/32 и выполним команду clear ip eigrp 1 neighbors
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!

Посмотрим на таблицу топологии.

Особенности EIGRP Router-ID

Префиксов опять нет!!! И маршрутизатор все еще использует Router-ID = 2.2.2.2 в таблице топологий, хотя адрес Loopback интерфейса мы поменяли. Чтобы изменения с интерфейсом вступили в силу, нужно заново настроить протокол EIGRP на этом маршрутизаторе. Пока не будем этого делать. Есть другой способ назначить Router-ID - это использовать команду eigrp router-id

router eigrp 1
  eigrp router-id 3.3.3.3

Выполним это и пересоберем соседство clear ip eigrp 1 neighbors

Особенности EIGRP Router-ID

Теперь в таблице топологий Router ID изменился на 3.3.3.3 и даже появились искомые префиксы. Смотрим таблицу маршрутизации на R1:

Особенности EIGRP Router-ID

Маршруты появились, проблема решена!скачать dle 10.6фильмы бесплатно
Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Комментарии:

Оставить комментарий
 

CCIENetLab (C)