Сделать домашней|Добавить в избранное
 

CCIENetLab - Подготовка к экзаменам
CCNA, CCNP и CCIE

 
» » Технология расщепление горизонта Split horizon в EIGRP

Технология расщепление горизонта Split horizon в EIGRP

Автор: Sauron от 8-06-2015, 19:36
Для предотвращения появления петель маршрутизации и зацикливания пакетов протоколы маршрутизации используют метод расщепления горизонта или split horizon.
Согласно технологии Split-Horizon маршрутизатор не будет распространять информацию об определенном маршруте через интерфейс, который является источником данной информации. Другими словами, маршрутизатор не будет информировать своего соседа, от которого была получена информация о маршруте к получателю.

Использование метода расщепления горизонта основано на том, что , как правило, нет необходимости в отправке информации о маршруте в обратном направлении, точнее в том направлении, от которого данный маршрут поступил. С точки зрения здравого смысла и правил маршрутизации такой подход является оптимальным. Но в некоторых конфигурациях сетей может оказаться целесообразным НЕ использовать механизм расщепления горизонта и необходимо отключать его. Отключение производится для каждого интерфейса отдельно. Примером когда требуется отключать технологию split-horizon может являться динамическая маршрутизация в DMVPN сетях, Frame-Relay Point-to-Multipoint сетях и т.п

Рассмотрим следующую сетевую топологию
Технология расщепление горизонта Split horizon в EIGRP

Маршрутизаторы R1, R2, R3 подключены к Frame-Relay облаку. Причем R1 подключен по технологии Point-to-Multipoint, а R2 и R3 по технологии Point-to-Point. Таким образом R2 и R3 могут обмениваться трафиком только через R1. На каждом роутере также настроен Loopback адрес. EIGRP включён на всех интерфейсах

Конфигурация R1:
hostname R1
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0

interface Ethernet0/0
 ip address 136.1.100.1 255.255.255.0
 no shut
!         
interface Serial1/0
 ip address 155.1.0.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.0.3 103 broadcast
 frame-relay map ip 155.1.0.2 102 broadcast
 no frame-relay inverse-arp
 no shut
!
router eigrp 100
 network 150.1.0.0
 network 155.1.0.0 0.0.0.255
 network 136.1.100.0 0.0.0.255
!


Конфигурация R2:
hostname R2
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0

interface Ethernet0/0
 ip address 136.1.110.2 255.255.255.0
 no shut              
!         
interface Serial1/0
 encapsulation frame-relay
 no shut
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.2 255.255.255.0
 frame-relay interface-dlci 201   
!
router eigrp 100
 network 136.1.110.0 0.0.0.255
 network 150.1.0.0
 network 155.1.0.0 0.0.0.255
!


Конфигурация R3:
hostname R3
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0

interface Ethernet0/0
 ip address 136.1.120.3 255.255.255.0
 no shut
!         
interface Serial1/0
 encapsulation frame-relay
 no shut
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.3 255.255.255.0
 frame-relay interface-dlci 301   
!
router eigrp 100
 network 136.1.120.0 0.0.0.255
 network 150.1.0.0
 network 155.1.0.0 0.0.0.255
!


Посмотрим таблицу маршрутизации на R1
Технология расщепление горизонта Split horizon в EIGRP

Из вывода мы видим что хосты из сети 136.1.100.0/24 могут взаимодействовать со всеми сетями R2 и R3 (136.1.110.0/24 и 136.1.120.0/24). Но посмотрим, могут ли сети R2 и R3 обмениваться между собой. Таблица маршрутизации на R2 выглядит так.

Технология расщепление горизонта Split horizon в EIGRP

У R2 почему-то нет маршрута к сети 136.1.120.0/24. Таким образом маршрутизаторы R2 и R3 не получают информацию друг о друге и следовательно сети 136.1.110.0/24 и 136.1.120.0/24 не взаимодействуют!
В силу вступила технология расщепления горизонта, тем самым заблокировав работу сети. Маршрутная информация, приходя на R1 не уходила дальше, так как во всех этих процессах был задействован один и тот же интерфейс (s1/0), который был и приемником и передатчиком для сетей 136.1.110.0/24 и 136.1.120.0/24
Для исправления этой ситуации следует отменить split horizon на интерфейсе Serial1/0 маршрутизатора R1 с помощью команды no ip split-horizon eigrp
Но Давайте проверим с помощью команды show ip interface s1/0:

Технология расщепление горизонта Split horizon в EIGRP

Как видим из данного вывода, split-horizon - уже выключен, а маршрутов нет.
Сюрприз ???

И в этот момент можно легко растеряться. На самом деле эта строка говорит лишь о том, что split horizon выключен для протокола RIP. А для протокола EIGRP надо посмотреть вывод команды show ip eigrp interfaces detail s1/0 (появилась в IOS 15.x)
Технология расщепление горизонта Split horizon в EIGRP

Оказывается split-horizon включен для протокола EIGRP. Выключаем его.

Технология расщепление горизонта Split horizon в EIGRP

А теперь проверим таблицу маршрутизации на R2

Технология расщепление горизонта Split horizon в EIGRP

Появился маршрут. Теперь на R1 маршрутная информация сможет распространятся из того же интерфейса на котором она была принята и сети за R2 и R3 могут взаимодействовать друг с другом.

Посмотрим еще раз вывод команды show ip eigrp interfaces detail s1/0 на R1

Технология расщепление горизонта Split horizon в EIGRP

Все правильно. Технология split horizon отключена для EIGRP. Кстати с помощью данной команды можно посмотреть и EIGRP таймеры на интерфейсе. Hello-interval составляет 60 сек, а Hold-time = 180, что является значениями по умолчанию для Serial интерфейсов. Эта единственная команда через которую можно увидеть Hello и Hold таймеры для EIGRP на интерфейсе.скачать dle 10.6фильмы бесплатно
Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Комментарии:

Оставить комментарий
 

CCIENetLab (C)